import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?0*3*0*|[^\\s\\d]";
final String string = "+331234567\n"
+ "+3301234567\n"
+ "00331234567\n"
+ "003301234567\n"
+ "0331234567\n"
+ "033-123-456-7\n"
+ "0033.1234567";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}