import re
regex = re.compile(r"^\+?0*3*0*|[^\s\d]", flags=re.MULTILINE)
test_str = ("+331234567\n"
"+3301234567\n"
"00331234567\n"
"003301234567\n"
"0331234567\n"
"033-123-456-7\n"
"0033.1234567")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)