using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(;\s*charset\s*=.[^\;]+)";
string input = @"application/vnd.obi.companion.customer+json;version=1; charset=ISO-8859-1 ; return null;
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}