package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(;\s*charset\s*=.[^\;]+)`)
var str = `application/vnd.obi.companion.customer+json;version=1; charset=ISO-8859-1 ; return null;
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}