re = /(;\s*charset\s*=.[^\;]+)/
str = 'application/vnd.obi.companion.customer+json;version=1; charset=ISO-8859-1 ; return null;
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end