const regex = /(;\s*charset\s*=.[^\;]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(;\\s*charset\\s*=.[^\\;]+)', '')
const str = `application/vnd.obi.companion.customer+json;version=1; charset=ISO-8859-1 ; return null;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}