$re = '/(;\s*charset\s*=.[^\;]+)/';
$str = 'application/vnd.obi.companion.customer+json;version=1; charset=ISO-8859-1 ; return null;
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);