# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!\B"[^"]*),(?![^"]*"\B)/\|/gm;t' <<< "aaa,bbb,ccc,\"ddd,eee\",\"fff,ggg\"
\"aaa,bbb\",ccc,ddd,\"eee,fff\"
\"aaa,bbb\",\"ccc,ddd\",\"eee,fff\",ggg
"