using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\B""[^""]*),(?![^""]*""\B)";
string substitution = @"\|";
string input = @"aaa,bbb,ccc,""ddd,eee"",""fff,ggg""
""aaa,bbb"",ccc,ddd,""eee,fff""
""aaa,bbb"",""ccc,ddd"",""eee,fff"",ggg
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}