$re = '/(?!\B"[^"]*),(?![^"]*"\B)/m';
$str = 'aaa,bbb,ccc,"ddd,eee","fff,ggg"
"aaa,bbb",ccc,ddd,"eee,fff"
"aaa,bbb","ccc,ddd","eee,fff",ggg
';
$subst = "\|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;