#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!\B"[^"]*),(?![^"]*"\B)"
Local $sString = "aaa,bbb,ccc,"ddd,eee","fff,ggg"" & @CRLF & _
""aaa,bbb",ccc,ddd,"eee,fff"" & @CRLF & _
""aaa,bbb","ccc,ddd","eee,fff",ggg" & @CRLF & _
""
Local $sSubst = "\|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)