using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+ISHOULDNOTBEHERE.+\n.+\n<\/myXMLTag>";
string input = @"<myXMLTag id=""Text1.Text2.Text3"">
<Anything/>
</myXMLTag>
<myXMLTag id=""Text1.ISHOULDNOTBEHERE.Text3"">
<Anything/>
</myXMLTag>
<myXMLTag id=""Text1.Text2.Text3"">
<Anything/>
</myXMLTag>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}