// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).+ISHOULDNOTBEHERE.+\n.+\n<\/myXMLTag>").unwrap();
let string = "<myXMLTag id=\"Text1.Text2.Text3\">
<Anything/>
</myXMLTag>
<myXMLTag id=\"Text1.ISHOULDNOTBEHERE.Text3\">
<Anything/>
</myXMLTag>
<myXMLTag id=\"Text1.Text2.Text3\">
<Anything/>
</myXMLTag>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}