import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+ISHOULDNOTBEHERE.+\\n.+\\n<\\/myXMLTag>";
final String string = "<myXMLTag id=\"Text1.Text2.Text3\">\n"
+ " <Anything/>\n"
+ "</myXMLTag>\n"
+ "<myXMLTag id=\"Text1.ISHOULDNOTBEHERE.Text3\">\n"
+ " <Anything/>\n"
+ "</myXMLTag>\n"
+ "<myXMLTag id=\"Text1.Text2.Text3\">\n"
+ " <Anything/>\n"
+ "</myXMLTag>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}