re = /.+ISHOULDNOTBEHERE.+\n.+\n<\/myXMLTag>/m
str = '<myXMLTag id="Text1.Text2.Text3">
<Anything/>
</myXMLTag>
<myXMLTag id="Text1.ISHOULDNOTBEHERE.Text3">
<Anything/>
</myXMLTag>
<myXMLTag id="Text1.Text2.Text3">
<Anything/>
</myXMLTag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end