package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<jira_id>(BIZ|FX|HUB|KTC|MPO|OEAMTC|ORG|PACOS|REDMINE|ROAD|SERVICE)-\d+)`)
var str = `HUB-60
FX-11111
TEST-123
ORG-789
FX-ABC
FX-
asdsd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}