re = /(?P<jira_id>(BIZ|FX|HUB|KTC|MPO|OEAMTC|ORG|PACOS|REDMINE|ROAD|SERVICE)-\d+)/m
str = 'HUB-60
FX-11111
TEST-123
ORG-789
FX-ABC
FX-
asdsd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end