$re = '`(?P<jira_id>(BIZ|FX|HUB|KTC|MPO|OEAMTC|ORG|PACOS|REDMINE|ROAD|SERVICE)-\d+)`m';
$str = 'HUB-60
FX-11111
TEST-123
ORG-789
FX-ABC
FX-
asdsd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);