import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<jira_id>(BIZ|FX|HUB|KTC|MPO|OEAMTC|ORG|PACOS|REDMINE|ROAD|SERVICE)-\\d+)";
final String string = "HUB-60\n"
+ "FX-11111\n"
+ "TEST-123\n"
+ "ORG-789\n"
+ "FX-ABC\n"
+ "FX-\n"
+ "asdsd\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}