import re
regex = re.compile(r"(?P<jira_id>(BIZ|FX|HUB|KTC|MPO|OEAMTC|ORG|PACOS|REDMINE|ROAD|SERVICE)-\d+)", flags=re.MULTILINE)
test_str = ("HUB-60\n"
"FX-11111\n"
"TEST-123\n"
"ORG-789\n"
"FX-ABC\n"
"FX-\n"
"asdsd\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")