#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![ ])(?!.*[ ]{1})(?:([A-Z][a-z]+\s*?)([Mc|O']*[A-Z][a-z]+\s*?)*(?!.*[ ])$)+$"
Local $sString = "BellGardens" & @CRLF & _
"Ronald McDonald" & @CRLF & _
"Brian O'Conner" & @CRLF & _
"Bell Gardens" & @CRLF & _
"BellGardens " & @CRLF & _
" BellGardens" & @CRLF & _
"RonaldMcDonald" & @CRLF & _
"BrianO'Conner" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")