re = /^(?![ ])(?!.*[ ]{1})(?:([A-Z][a-z]+\s*?)([Mc|O']*[A-Z][a-z]+\s*?)*(?!.*[ ])$)+$/m
str = 'BellGardens
Ronald McDonald
Brian O\'Conner
Bell Gardens
BellGardens
BellGardens
RonaldMcDonald
BrianO\'Conner
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end