import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![ ])(?!.*[ ]{1})(?:([A-Z][a-z]+\\s*?)([Mc|O']*[A-Z][a-z]+\\s*?)*(?!.*[ ])$)+$";
final String string = "BellGardens\n"
+ "Ronald McDonald\n"
+ "Brian O'Conner\n"
+ "Bell Gardens\n"
+ "BellGardens \n"
+ " BellGardens\n"
+ "RonaldMcDonald\n"
+ "BrianO'Conner\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}