$re = '/^(?![ ])(?!.*[ ]{1})(?:([A-Z][a-z]+\s*?)([Mc|O\']*[A-Z][a-z]+\s*?)*(?!.*[ ])$)+$/m';
$str = 'BellGardens
Ronald McDonald
Brian O\'Conner
Bell Gardens
BellGardens
BellGardens
RonaldMcDonald
BrianO\'Conner
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);