const regex = /^(?![ ])(?!.*[ ]{1})(?:([A-Z][a-z]+\s*?)([Mc|O']*[A-Z][a-z]+\s*?)*(?!.*[ ])$)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![ ])(?!.*[ ]{1})(?:([A-Z][a-z]+\\s*?)([Mc|O\']*[A-Z][a-z]+\\s*?)*(?!.*[ ])$)+$', 'gm')
const str = `BellGardens
Ronald McDonald
Brian O'Conner
Bell Gardens
BellGardens
BellGardens
RonaldMcDonald
BrianO'Conner
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}