package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[0-9]*\s*[pP](?:\.O\.|o)(?:st(?:al)?\soffice\s)*[bB]ox(?:\sstreet)?)$`)
var str = `P.O.Box
pobox
post office box
box
BOX
poor box etc.,
1234 post office box street
123 postal office box
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}