import re
regex = re.compile(r"^(?:[0-9]*\s*[pP](?:\.O\.|o)(?:st(?:al)?\soffice\s)*[bB]ox(?:\sstreet)?)$", flags=re.MULTILINE)
test_str = ("P.O.Box\n"
"pobox\n"
"post office box\n"
"box\n"
"BOX\n"
"poor box etc.,\n"
"1234 post office box street\n"
"123 postal office box\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")