re = /^(?:[0-9]*\s*[pP](?:\.O\.|o)(?:st(?:al)?\soffice\s)*[bB]ox(?:\sstreet)?)$/m
str = 'P.O.Box
pobox
post office box
box
BOX
poor box etc.,
1234 post office box street
123 postal office box
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end