import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-9]*\\s*[pP](?:\\.O\\.|o)(?:st(?:al)?\\soffice\\s)*[bB]ox(?:\\sstreet)?)$";
final String string = "P.O.Box\n"
+ "pobox\n"
+ "post office box\n"
+ "box\n"
+ "BOX\n"
+ "poor box etc.,\n"
+ "1234 post office box street\n"
+ "123 postal office box\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}