#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!Copy).*?-(\d{6})\.v"
Local $sString = "BS-123456.v2019" & @CRLF & _
"Copy_BS-123456.v2019" & @CRLF & _
"Copy-BS-123456.v2019" & @CRLF & _
"Copy BS-123456.v2019"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")