import re
regex = re.compile(r"^(?!Copy).*?-(\d{6})\.v", flags=re.MULTILINE)
test_str = ("BS-123456.v2019\n"
"Copy_BS-123456.v2019\n"
"Copy-BS-123456.v2019\n"
"Copy BS-123456.v2019")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")