$re = '`^(?!Copy).*?-(\d{6})\.v`m';
$str = 'BS-123456.v2019
Copy_BS-123456.v2019
Copy-BS-123456.v2019
Copy BS-123456.v2019';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);