re = /^(?!Copy).*?-(\d{6})\.v/m
str = 'BS-123456.v2019
Copy_BS-123456.v2019
Copy-BS-123456.v2019
Copy BS-123456.v2019'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end