using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^0-9]|^)[17][0-9]{6}([0-9]{3})?([^0-9]|$)";
string input = @".........1234567......."", domain_string2 = "".......7192839265......"", etc)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}