$re = '/([^0-9]|^)[17][0-9]{6}([0-9]{3})?([^0-9]|$)/m';
$str = '.........1234567.......", domain_string2 = ".......7192839265......", etc)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);