package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^0-9]|^)[17][0-9]{6}([0-9]{3})?([^0-9]|$)`)
var str = `.........1234567.......", domain_string2 = ".......7192839265......", etc)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}