const regex = new RegExp('([^0-9]|^)[17][0-9]{6}([0-9]{3})?([^0-9]|$)', 'gm')
const str = `.........1234567.......", domain_string2 = ".......7192839265......", etc)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}