re = /([^0-9]|^)[17][0-9]{6}([0-9]{3})?([^0-9]|$)/m
str = '.........1234567.......", domain_string2 = ".......7192839265......", etc)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end