const regex = /^(?P<header>[^:\n]+):\s*(?P<value>.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<header>[^:\\n]+):\\s*(?P<value>.+)', 'gm')
const str = `ID: 1
Name: Jon Doe
Address: 123 Main St Anytown, USA
Age: 25`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}