re = /^(?P<header>[^:\n]+):\s*(?P<value>.+)/m
str = 'ID: 1
Name: Jon Doe
Address: 123 Main St Anytown, USA
Age: 25'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end