$re = '/^(?P<header>[^:\n]+):\s*(?P<value>.+)/m';
$str = 'ID: 1
Name: Jon Doe
Address: 123 Main St Anytown, USA
Age: 25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);