import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\p{Lu}\\w+)=(\\s?[.\\s@\\w\\-]+)";
final String string = "Dec 17 10:08:38 10.52.137.1 Apr 3 22:46:57 2012 930|RTR-944 %%10SC/6/SC_AAA_LAUNCH(l): |DevIP=10.52.137.1|AAAType=AUTHEN|AAAScheme= hwtacacs-scheme tacacs|Service=login|UserName=monitor@system; AAA launched.\n"
+ "DevIP=10.52.137.1|AAAType=AUTHEN|AAAScheme= hwtacacs-scheme tacacs|Service=login|UserName=monitor@system";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}