$re = '/(\p{Lu}\w+)=(\s?[.\s@\w\-]+)/';
$str = 'Dec 17 10:08:38 10.52.137.1 Apr 3 22:46:57 2012 930|RTR-944 %%10SC/6/SC_AAA_LAUNCH(l): |DevIP=10.52.137.1|AAAType=AUTHEN|AAAScheme= hwtacacs-scheme tacacs|Service=login|UserName=monitor@system; AAA launched.
DevIP=10.52.137.1|AAAType=AUTHEN|AAAScheme= hwtacacs-scheme tacacs|Service=login|UserName=monitor@system';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);