using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\p{L}['´ \-]?)+(?<=[^\s\-'´])$";
string input = @"Valid firstnames:
-----------------
Jean-Jacques
O'Neill
O´Neill
De Lee
Élodie
Michèle
Invalid first names:
--------------------
Bertrand!
Focus123
Spaceafter
Space before
Two spaces
Hyphen-at-end-
Two--hyphens
Ooo´
1234
email@domain.com
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}