re = /^(?:\p{L}['´ \-]?)+(?<=[^\s\-'´])$/m
str = 'Valid firstnames:
-----------------
Jean-Jacques
O\'Neill
O´Neill
De Lee
Élodie
Michèle
Invalid first names:
--------------------
Bertrand!
Focus123
Spaceafter
Space before
Two spaces
Hyphen-at-end-
Two--hyphens
Ooo´
1234
email@domain.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end