# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\p{L}['´ \-]?)+(?<=[^\s\-'´])$"
test_str = ("Valid firstnames:\n"
"-----------------\n\n"
"Jean-Jacques\n"
"O'Neill\n"
"O´Neill\n"
"De Lee\n"
"Élodie\n"
"Michèle\n\n"
"Invalid first names:\n"
"--------------------\n\n"
"Bertrand!\n"
"Focus123\n"
"Spaceafter \n"
" Space before\n"
"Two spaces\n"
"Hyphen-at-end-\n"
"Two--hyphens\n"
"Ooo´\n"
"1234\n"
"email@domain.com\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.