use strict;
my $str = 'Valid firstnames:
-----------------
Jean-Jacques
O\'Neill
O´Neill
De Lee
Élodie
Michèle
Invalid first names:
--------------------
Bertrand!
Focus123
Spaceafter
Space before
Two spaces
Hyphen-at-end-
Two--hyphens
Ooo´
1234
email@domain.com
';
my $regex = qr/^(?:\p{L}['´ \-]?)+(?<=[^\s\-'´])$/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}