using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s|^)(Prefix:[a-zA-Z0-9][\w.-]*[^.]#\d+)(?:\s|$)";
string input = @"Prefix:middle#113 build: xxxxxx Prefix:middle#6
Prefix:middle#16026Prefix:middle#1111
Prefix:middle#110 Prefix:middle.#2 Prefix:middl.e#111 Prefix:middle#112";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}