re = /(?:\s|^)(Prefix:[a-zA-Z0-9][\w.-]*[^.]#\d+)(?:\s|$)/m
str = 'Prefix:middle#113 build: xxxxxx Prefix:middle#6
Prefix:middle#16026Prefix:middle#1111
Prefix:middle#110 Prefix:middle.#2 Prefix:middl.e#111 Prefix:middle#112'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end