const regex = new RegExp('(?:\\s|^)(Prefix:[a-zA-Z0-9][\\w.-]*[^.]#\\d+)(?:\\s|$)', 'gm')
const str = `Prefix:middle#113 build: xxxxxx Prefix:middle#6
Prefix:middle#16026Prefix:middle#1111
Prefix:middle#110 Prefix:middle.#2 Prefix:middl.e#111 Prefix:middle#112`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}